Hurricane Milton
Incident Report for SimpleVoIP LLC
Resolved
The worst of the storm's impact has passed. We understand that many locations in Milton's path are still without utilities or inoperable due to damage or flooding. Please let our team know if we can be of any additional assistance to get you through this difficult time.
Posted Oct 15, 2024 - 09:45 PDT
Monitoring
If any locations are impacted due to the severe weather caused by Hurricane Milton, we have options to help. Our Marketing Message feature can be repurposed to play an emergency notice before any standard IVR messaging, and you can utilize Call Forwarding to redirect calls away from any locations that can’t take calls onsite. If you have any other questions or concerns, or if we can help out in any way, please contact our Support team at support@simplevoip.com or call 855-899-8647.
Posted Oct 09, 2024 - 19:04 PDT
This incident affected: SimpleVoIP Hosted PBX.