Call Completion - Eastern
Incident Report for SimpleVoIP LLC
Resolved
This incident has been resolved.
Posted May 05, 2023 - 08:56 PDT
Monitoring
We received reports at approximately 8:30 am CST that inbound callers were unable to reach locations homed in the Eastern region. After investigating, we determined the issue and implemented a fix at 8:50 am CST. Calls are routing appropriately at this time. Please report any further issues to support@simplevoip.com.
Posted May 05, 2023 - 07:05 PDT
This incident affected: SimpleVoIP Hosted PBX.