Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 02, 2025 - 20:00 PDT
Scheduled
We are updating our SSL certificates prior to the expiration of the old certificates to ensure that all of our secure services continue to function. This will involve a rolling, graceful restart of some of our voice services, meaning that the vast majority of traffic will be uninterrupted. There is a chance that long-running calls (>30 mins) may drop as the service is restarted. No other impact is expected.
If you have any questions or concerns, please contact our Support team at support@simplevoip.com.
Posted Mar 31, 2025 - 13:56 PDT
This scheduled maintenance affected: SimpleVoIP Hosted PBX.