We've observed that all systems have remained stable since the service restarts. Our Engineering team will continue to monitor closely, though we are marking this as Resolved at this time.
Posted Nov 27, 2024 - 11:10 PST
Monitoring
We observed higher than usual CPU utilization on several servers, which contributed to increased Post-Dial Delay, as well as some outbound call failures. We've restarted the affected servers and are seeing normal CPU utilization.
Posted Nov 27, 2024 - 10:08 PST
Investigating
We are investigating reports of some calls not completing on our system. We will provide updates as soon as we have identified the cause and impact of this event.