Call completion
Incident Report for SimpleVoIP LLC
Resolved
An issue was identified with one of our inbound carriers. This began at approximately 20:49 UTC and lasted until 21:57 UTC.

This has been resolved. Calls are now completing normally to all locations.
Posted 5 months ago. Jul 31, 2018 - 15:25 PDT
Investigating
There are reports of inbound calls failing to multiple customer locations from a variety of external carriers.
Posted 5 months ago. Jul 31, 2018 - 15:22 PDT
This incident affected: SimpleVoIP Hosted PBX.