Inbound calling issues post-maintenance
Incident Report for SimpleVoIP LLC
Postmortem

Incident Details and Remediation Steps

Following the maintenance to migrate all services to our new private cloud environment, we discovered that some of our phone number records had not synchronized to the new private cloud environment. This was preventing inbound calls from being delivered to the affected users. We started work right away to resync our numbers to restore service to those affected users.

This was complicated by the nature of the phone number records on our system: there is a global phone number database that tells the system which account or subaccount to send calls to for a particular number, and an account-level database that tells the system where to route those calls once they’ve reached the specific account. The earliest sync issues that we discovered were numbers that were present in the global database but not at the account level, and that’s where we began with the repair process.

Once we resynced those numbers, we discovered that there were also some scattered numbers that were in the individual accounts databases but had not synced to the global database, to the same effect from an end user’s perspective. So rather than pushing those records down from the global database to the account level, we then had to push them from the account level back up to the global. This account-by-account process was slower and was part of the reason that some sites had service restored earlier than others (other reasons being that some sites were not affected at all, or were only affected by the global-to-account sync issue that was fixed earlier).

Future Prevention

The migration to the new private cloud infrastructure carried some significant risks, and it did cause disruptions, for which we are truly sorry. This particular outage’s root cause was unique to this migration process, and as a result it will not occur again.

Posted May 15, 2019 - 07:25 PDT

Resolved
We uncovered some scattered sites through the day that needed additional work to correct their inbound call service. At this point, that work is complete and all inbound numbers should be working properly. If you have any sites that are experiencing call completion issues, please reach out to our support team.
Posted Apr 22, 2019 - 18:51 PDT
Monitoring
We have applied the fix to all sites, and functionality should be fully restored at this point. We are performing some additional checks to verify. If you are still experiencing any issues, please let our support team know.
Posted Apr 22, 2019 - 07:13 PDT
Update
Our engineering team has confirmed the scope of the issue and begun implementing a fix. This fix is applied on each individual subaccount, so some locations may have inbound functionality restored earlier than others. We hope to have all numbers back to full functionality within the hour.
Posted Apr 22, 2019 - 06:36 PDT
Identified
We have identified an issue affecting inbound calling for a subset of customers as a result of last night's maintenance. Calls to the affected numbers are not being delivered. Outbound calling is not affected. Our engineers are working to fix the issue as quickly as possible.
Posted Apr 22, 2019 - 05:59 PDT
This incident affected: SimpleVoIP Hosted PBX.