Call Completion
Incident Report for SimpleVoIP LLC
Resolved
This issue has been resolved. Thank you for your patience.
We isolated the issue to an IP routing problem at Amazon AWS, where we use servers to process certain functionality, including API calls from our call processing servers (not located within AWS). The functionality includes advanced Auto Attendants with SMS functionality, the ability to forward calls off of our network, customer database integrations and other advanced functionality. The IPs shared by our servers were not consistently reachable from our core voice infrastructure, which caused these calls to fail.

Instead of waiting for Amazon to fix the routing problem, we opted to procure new IPs and update our DNS, which is set to a 5 minute TTL.

All systems have now been tested and are operational.

We are sorry for the inconvenience this event caused.
Posted 9 months ago. Feb 05, 2018 - 14:01 PST
Update
We are still working on a fix for this issue.
Posted 9 months ago. Feb 05, 2018 - 11:54 PST
Update
The issue has been isolated to API calls and off-system Pivot functionality. This can affect complex auto attendants, call forwarding off-net and SMS messaging. We are working with our software provider on a fix.
Posted 9 months ago. Feb 05, 2018 - 10:55 PST
Identified
Issue has been identified and only affects certain inbound Auto Attendants using advanced API functionality. We are implementing a workaround.
Posted 9 months ago. Feb 05, 2018 - 09:32 PST
Investigating
We are investigating reports of some calls not completing on our system. We will provide updates as soon as we have identified the cause and impact of this event.
Posted 9 months ago. Feb 05, 2018 - 09:00 PST