Call Completion

Incident Report for SimpleVoIP LLC

Resolved

Call routing has fully stabilized and traffic patterns have returned to normal.

The earlier disruption was tied to upstream carrier routing paths correlated with the broader Cloudflare incident. Upstream providers have implemented mitigations and routing has remained stable following those changes.

All inbound and outbound calling services are fully operational at this time.

We will continue passive monitoring, but no further impact is expected. Thank you for your patience while this was investigated and resolved.
Posted Feb 20, 2026 - 12:14 PST

Monitoring

Inbound calling has been restored and call traffic has normalized as of approximately 10 minutes ago.

Upstream carriers, in coordination with Cloudflare, have identified and implemented workarounds for the underlying routing issues that were impacting certain call paths.

At this time:

Inbound calling is operational

Outbound calling remains fully operational

We are continuing to monitor traffic closely to ensure stability. We will provide a final resolution update once the upstream incident has been fully closed.
Posted Feb 20, 2026 - 11:36 PST

Update

We have identified that this issue appears to be related to an upstream carrier and is correlated with the ongoing Cloudflare outage affecting portions of internet routing.

As a result, any call routes that traverse infrastructure impacted by the Cloudflare issue may experience disruption — even where the core SimpleVoIP platform remains fully operational.

At this time:

Outbound calling is fully operational.

Inbound calling remains impacted for a subset of DIDs, depending on carrier routing paths.

We are actively working with our carrier partners and monitoring the broader Cloudflare incident. We will continue to provide updates as more information becomes available.
Posted Feb 20, 2026 - 11:13 PST

Investigating

We are investigating reports of some calls not completing on our system. We will provide updates as soon as we have identified the cause and impact of this event.
Posted Feb 20, 2026 - 11:02 PST
This incident affected: SimpleVoIP Hosted PBX (Core Voice Services).